Problème fonctionnement de l'USB CDC

Forum de discussion sur les microcontrôleurs XMEGA
Répondre
petitclem
NOUVEAU
NOUVEAU
Messages : 1
Enregistré le : 01 oct. 2014 17:52

Problème fonctionnement de l'USB CDC

Message par petitclem » 02 oct. 2014 8:32

Bonjour,

j'utilise un microcontrôleur xmega128A3U soudé sur une carte personalisée, je programme avec AVR Studio 6.1, et je souhaite utiliser ASF pour configurer mon microcontrôleur. ASF est bien installé, j'ai créé un nouveau projet avec "user board", le programme compile et est exécuté sur mon microcontrôleur mais mon système d’exploitation (windows) ne détecte pas ma carte après la commande « udc_start(); ».
J'ai suivi ce tuto « Connexion USB CDC avec votre XMEGA » sur cette page http://www.jelectronique.com/?p=68#comment-26 .

Merci d’avance pour votre retour
A bientôt

JP
Administrateur
Administrateur
Messages : 2323
Enregistré le : 23 sept. 2003 18:14
Localisation : Strasbourg
Contact :

Re: Problème fonctionnement de l'USB CDC

Message par JP » 03 oct. 2014 20:40

Bonjour Clem,

Un problème hardware est envisageable sur ta carte ? Tu l'as déjà validé avec un autre soft ?
Sinon, tu pourrais peut être essayer sur un autre PC. Parfois la première détection d'un périphérique se fait mal, le driver n'est pas correctement installé et dès que tu rebranches le périphérique il se met en erreur.
A voir aussi dans le gestionnaire de périphérique s'il n'apparait pas en tant que périphérique inconnu.
(windows) ne détecte pas ma carte après la commande « udc_start(); ».
Tu as un son windows de détection USB, le "ding dung" ou rien du tout ?

Si tu n'as rien, il y a peut être un problème de paramétrage de l'horloge.
Si tu m'envoies ton projet, je pourrais peut être essayer de le faire tourner sur mon xmega256

a+
JP
Ca clignote !!!!

Répondre